PHP 7 support

Hi all,

One week in, and the new site hasn’t completely melted yet! Hell, I’d consider that a triumph! 😉

Naturally I’ll continue to patch any bugs that come in, but I’ll soon be turning my attention to the actual Form Tools codebase, starting with….

PHP 7 support

By far the most important thing to address is getting Form Tools to run on PHP7. I’m sorry this has taken so long to address, but the site & moving to code to github had to come first. PHP7 dropped a few things, such as the database functions that Form Tools relies on, so I need to roll out updates to every module, the core and the API.

I’ll be starting with the System Check module (to let you know if you can safely upgrade) followed by the Form Tools core.

I’ll do a follow-up post (or maybe post on twitter) with how things are coming along.

Ben

 

This entry was posted in News. Bookmark the permalink.

4 Responses to PHP 7 support

  1. Steve Andrews says:

    Thank you so much for all of your hard work! Form Tools is fantastic!

  2. admin says:

    Thanks, Steve! 🙂

  3. Brandon says:

    Hi Ben! Glad to see you working with FormTools again! With your updates to PHP7, it would be extra special if you could provide backwards compatibility. Or at least reference that a certain core version is designed to work with which version of PHP. Currently we are still running 5.4.45.

  4. admin says:

    Yup, no problem! The new version will require PHP 5.3 or later and PDO support (which shipped with PHP 5.1) so you should be good. 🙂

Leave a Reply